r3wp [groups: 83 posts: 189283]
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

World: r3wp

[!REBOL3 GUI]

Cyphre
19-Mar-2011
[6897]
Jocko, rgearding the: circle: [pair! | number! | number!] definition.

This is correct as the definition doesn't describe the exact syntax 
of the command but it works more like the rules used by DELECT.

So in this case the CIRCLE command can be used only in these combination:
circle pair! number!
circle pair! number! number! 


which corresponds to the syntax described here: http://www.rebol.com/r3/docs/view/draw-curves.html#section-3


Ofcourse, now when the float pair! has been implemented we could 
extend the syntax for another pair to:
circle: [pair! | pair! | number! | number!]
to allow also:
circle pair! pair!


but this change needs to be reflected also in the to-draw function 
and dialect-draw definition object used by DELECT in the R3GUI.


I'll add this enhancement so it will be available in the next RMA 
release for you.


Also note, the current DRAW dialect (implemented by the preprocessor 
mezzanines) is trying to reflect only  the R3 draw reference documentation 
(in the link above) syntax which has been designed at the time the 
float pair! was not available. The review of the syntax is planned 
in the future.
jocko
22-Mar-2011
[6898]
Cyphre, thank you for the info and the link.

Please don't do special changes for me, unless you see a real interest 
to do so.
Ladislav
31-Mar-2011
[6899]
User poll, which of the following refinement names would you prefer?

    UPDATE-FACE/CONTENT

, or

    UPDATE-FACE/CONTENTS

?
PeterWood
31-Mar-2011
[6900]
Contents sounds more natural to me so I'll vote for it.
Ladislav
31-Mar-2011
[6901]
That is what I thought was more "natural" for native english speakers 
too. But, looks like Cyphre (maybe other non-native speakers as well) 
is not used to it, (e.g. in Czech the equivalent "content" is usually 
singular).
PeterWood
31-Mar-2011
[6902x2]
For me, the differences in the two words is quite sublte. The word 
contents gives the impression of something more tangible than content. 
As an example, I would say the content of the book to refer to the 
overall meaning of the book. I would refer to the contents of the 
book as the list of chapters.
Though I'm not sure that examples is relevant in this case.
Ladislav
31-Mar-2011
[6904x3]
I think it is, thanks
Just to explain what should the meaning of the UPDATE-FACE/CONTENT(S) 
be. It shall be used to "signal", that something inside the face 
has been changed, and the face needs update.
It is used for panels, groups, windows, etc.
PeterWood
31-Mar-2011
[6907]
I'd still go for CONTENTS.
Ladislav
31-Mar-2011
[6908]
As opposed to that, when just UPDATE-FACE is called, it means only 
that the face dimensions have been changed.
PeterWood
31-Mar-2011
[6909x2]
Most people I know would say "The contents have changed" rather than 
"The content has changed" even though the second may be "more correct".
By the way, I probably should only be given 0.1 of a vote as I have 
hardly done any GUI programming with REBOL and certainly none with 
REBOL3.
Ladislav
31-Mar-2011
[6911]
Does not seem relevant in this case.
Henrik
31-Mar-2011
[6912]
should the name not be the same as the CONTENT(S) block of the face? 
if it's named CONTENT(S).
Ladislav
31-Mar-2011
[6913]
Yes, unification is necessary, correct, we just need to find which 
alternative is preferred.
PeterWood
31-Mar-2011
[6914]
I checked the Oxford English Dictionary for Content when referring 
to a container of some kind:


(usually in plural) what is contained in something, especially in 
a vessel, book or house.
Robert
31-Mar-2011
[6915x2]
As a non-native speaker CONTENTS sounds quite strange... and I wouldn't 
remember to add the S after a couple of weeks not using it.
Is CONTENT(S) the best word here? You said "to signal something inside 
the face changed, and the face needs to update". How about:
- DIRTY
- MEMBERS
- STATE
Ladislav
31-Mar-2011
[6917]
...after a couple of weeks not using it
 - in fact, there was UPDATE-FACE/CONTENTS from the start
Robert
31-Mar-2011
[6918]
:-) So, I might haven't found it at all yet.
Pekr
31-Mar-2011
[6919]
I am used to contents. But maybe I agree with Robert, that it does 
not clearly describe, what does it mean, so update-face/changed, 
update-face/dirty, would be more appropriate. Anyway - I voted for 
CONTENTS.
Ladislav
31-Mar-2011
[6920x2]
UPDATE-FACE is quite low-level, so you may not be forced to use the 
function at all.
Thanks, Pekr
GiuseppeC
31-Mar-2011
[6922]
My vote goes to: CONTENTS
Oldes
31-Mar-2011
[6923]
As a non native speaker, I would prefere just CONTENT
Gregg
31-Mar-2011
[6924]
'Content sounds singular; 'contents  sounds plural. Are there more 
cases than resizing and members changing to consider? It's a very 
general name, and 'content or 'contents doesn't add a lot of meaning 
to what it does exactly.
Geomol
31-Mar-2011
[6925]
What does UPDATE-FACE do without the refinement?
Ladislav
31-Mar-2011
[6926]
I wrote it above, did you find the post?
Geomol
31-Mar-2011
[6927]
Ah, saw it now, thanks.

As opposed to that, when just UPDATE-FACE is called, it means only 
that the face dimensions have been changed.
Ladislav
31-Mar-2011
[6928]
Because of the difference between UPDATE-FACE (meaning: face dimensions 
changed) and UPDATE-FACE/CONTENTS (meaning: face contents changed), 
neither of /DIRTY, /STATE makes sense to me. /MEMBERS instead of 
/CONTENTS looks more appropriate than the other alternatives, but 
still not preferable to /CONTENTS (at least to me).
Geomol
31-Mar-2011
[6929x3]
If you're not planning to have both refinements meaning different 
things, I'll go for CONTENT. But I'm also non native english speaking.
Both words are in my english->danish dictionary. The danish word 
is "indhold", and it can be both singular and plural.
If a book only has one chapter, will it be called "table of content"? 
:-) Sorry, I'm probably creating more confusion.
Ladislav
31-Mar-2011
[6932]
:-)
Geomol
31-Mar-2011
[6933]
http://en.wikipedia.org/wiki/Content
Funny it's called a "content provider", not "contents provider".
GrahamC
31-Mar-2011
[6934]
My understanding is that content refers to what is inside, contents 
refers to a list of the content
Geomol
31-Mar-2011
[6935]
After looking in dictionary on my computer, I'll say contents (plural) 
is more correct english.

The plural form:

the things that are held or included in something : he unscrewed 
the top of the flask and drank the contents | he picked up the correspondence 
and scanned the contents.
The singular:

the amount of a particular constituent occurring in a substance : 
milk with a low-fat content.
GrahamC
31-Mar-2011
[6936]
So I would be content with content
Geomol
31-Mar-2011
[6937x2]
:-)
Ok, from now on, all new words in REBOL will be in esperanto. English 
is too difficult!
Kaj
31-Mar-2011
[6939]
I think both forms would be correct, with contents a little more 
specific, and content a little more abstract, and shorter
AdrianS
31-Mar-2011
[6940]
when you have to move on short notice and you sell everything in 
your house, it's called a "contents sale"
GrahamC
31-Mar-2011
[6941x2]
Further explaining my explanation above, one would use contents when 
the items contained therein are easily numerated .. and content when 
it is not.  So, content provider because the items can not be easily 
enumerated, and vary from time to time.  So, on this basis one would 
use /contents because one can always enumerate the members of the 
object.
but if the object only had a single item, we would have to switch 
to use /content
Kaj
31-Mar-2011
[6943]
So in contents sale, it would mean all the content
GrahamC
31-Mar-2011
[6944]
in a contents sale, one can list each item ...
jocko
1-Apr-2011
[6945]
a suggestion for the next release of r3-gui : the doc style (the 
doc parser) interprets the first line of text as a title, which is 
not always appropriated. For instance, in a simple 

alert "this is an alert", the text is displayed as title. I think 
that this feature should be removed.
Cyphre
1-Apr-2011
[6946]
jocko, the DOC style is using the MDP markup now so my guess is we 
would rather use different style for alert layouts. We'll look into 
it.