Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

CGI and apparent "secure" issues!?!?!?

 [1/6] from: eric::ehrichweiss::com at: 25-Apr-2005 15:16

Does anyone have any idea why it is that if I call my rebol cgi program from my web server(Aprelium Abyss) that I can't get it to handle other network related functions like sending email via 'send [eric--ehrichweiss--com] "this message"'?? I can run a test script from the same directory and it will send me email but something to do with the "secure" function is what I suspect is causing me my issues. This is whether I call Core or View from the C:\rebol\view or the cgi-bin directory of the server. I thought at first it might not be seeing my smtp server but that doesn't seem to be the case. I do call it with the -cs arguements so that's not it. Anyone?

 [2/6] from: eric:ehrichweiss at: 25-Apr-2005 15:49

NEVER MIND!!!Re: CGI and apparent "secure" issues!?!?!?

Sheesh. Apparently the webserver isn't calling the script with the arguements like it should because when I told it to read the #! line, it worked fine. I'll just have to work with the developers to see if there's something else I should be doing... Eric Haddix wrote:

 [3/6] from: sags::apollo::lv at: 26-Apr-2005 0:10

I tried Rebol with an older version of Abys Now I am working in test cases with KFWS. With Abyss I had trouble to pass to Rebol multiple parameters/arguments. brgds Janeks On 25 Apr 2005 at 15:49, Eric Haddix wrote:

 [4/6] from: eric::ehrichweiss::com at: 25-Apr-2005 19:46

What types of parameters/arguements are you trying to pass? I've managed to get Abyss 2.0 X1(the new free version for now) to allow http uploads, and other general processing of web forms. If you need any assistance with this I'd be happy to help. Eric [sags--apollo--lv] wrote:

 [5/6] from: sags::apollo::lv at: 26-Apr-2005 22:56

I had no problems to get running Rebol on Abyss with -cs switch. I had unsucessfuly tried to run Rebol in a way: ..../rebol.exe -cs erebol.r pageWithEmbended.script But it was with older version of Abyss. Now I should check new version and doc's myself, but I have not yet motivation and time to do that, because now I am using for test purposes KF webserver, that was possible to set up to run Rebol in mode mentioned above. Janeks On 25 Apr 2005 at 19:46, Eric Haddix wrote:

 [6/6] from: eric::ehrichweiss::com at: 26-Apr-2005 16:24

I've been sucessfully running Abyss/Rebol to parse/execute embedded scripts for a few months now but it's not the way that some might think. For example, to get it to process my index.html file I have to create a preprocessor to load, parse and "print" it... eg. would load index.html, find embedded code and evaluate it and add it to the rest of the html file and respond to the browser. Maybe that's what you're trying to do? Since I don't exactly understand what you're trying to do, I can't comment on whether it's possible for you or not.. Eric [sags--apollo--lv] wrote: