Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

Rebol/View on Leopard

 [1/17] from: kpeters::otaksoft::com at: 21-Nov-2007 20:34


Has anyone got View running under Leopard - I end up getting bus errors all over the place.... Kai

 [2/17] from: Karim::elfounas::easybraine::com at: 22-Nov-2007 8:51


Hello, I'm just installing my dev environment on my new Mac and it seems that's working. I installed the SDK and I can run the desktop. I never saw any bus error but, I need to do more tests. Quoting Kai Peters <kpeters-otaksoft.com>:
> > Has anyone got View running under Leopard - I end up getting > bus errors all over the place.... > > Kai > > -- > To unsubscribe from the list, just send an email to > lists at rebol.com with unsubscribe as the subject. >
-- Karim EL FOUNAS EasyBraine SA Campagne des Rites, 8 - 1421 Ophain Bois-Seigneur-Isaac Tel: +32 (0)2 387 32 34 - Mobile: +32 (0)495 57 32 34 karim.elfounas-easybraine.com - www.easybraine.com

 [3/17] from: riacht::googlemail::com at: 22-Nov-2007 12:28


may be, you've already got the previous mail from me, because i had to resubscribe to the ML. so , my question is - on which hardware are you running the leopard? S. On Wed, Nov 21, 2007 at 08:34:58PM -0800, Kai Peters wrote:

 [4/17] from: edoconnor:gma:il at: 22-Nov-2007 9:10


I first installed View under Tiger, then upgraded to Leopard a few weeks ago and have had no problems with rebol. I have only clicked around the Viewtop and run some basic reblets, but everything seems fine on the surface. REBOL/View 1.3.2.2.4 7-Jan-2006 Core 2.6.3 Ed On Nov 21, 2007 11:34 PM, Kai Peters <kpeters-otaksoft.com> wrote:

 [5/17] from: henrik:webz:dk at: 22-Nov-2007 16:46


On 22/11/2007, at 15.10, Ed O'Connor wrote:
> I first installed View under Tiger, then upgraded to Leopard a few > weeks ago and have had no problems with rebol. > > I have only clicked around the Viewtop and run some basic reblets, but > everything seems fine on the surface.
I think you need to clarify if you are running it under Rosetta on an Intel Mac or on a PPC Mac. There is likely a difference. Some people report trouble, while it runs fine for other people. -- Regards, Henrik Mikael Kristensen

 [6/17] from: edoconnor:gma:il at: 22-Nov-2007 11:29


Ah, sorry. To clarify: I'm on Intel Mac. On Nov 22, 2007 10:46 AM, Henrik Mikael Kristensen wrote:

 [7/17] from: kpeters::otaksoft::com at: 22-Nov-2007 10:14


Mac Mini, 6 months old, 2 GB Ram, SuperDrive: All worked under Tiger - yesterday I upgraded.... View dies instantly under Leopard - the others run MiniMac:rebol-sdk kpeters$ cd tools/ MiniMac:tools kpeters$ ls -l total 11616 -rwxr-xr-x 1 kpeters staff 799876 20 Mar 2007 enbase -rwxr-xr-x 1 kpeters staff 1238148 20 Mar 2007 enface -rwxr-xr-x 1 kpeters staff 930948 20 Mar 2007 enpro -rw-r--r-- 1 kpeters staff 4803 20 Mar 2007 prebol.r -rw-r--r-- 1 kpeters staff 4216 20 Mar 2007 prerebol.r -rwxr-xr-x 1 kpeters staff 357492 20 Mar 2007 rebbase -rwxr-xr-x 1 kpeters staff 804392 20 Mar 2007 rebface -rwxr-xr-x 1 kpeters staff 390260 20 Mar 2007 rebol -rwxr-xr-x 1 kpeters staff 488764 20 Mar 2007 rebpro -rwxr-xr-x 1 kpeters staff 898600 20 Mar 2007 rebview MiniMac:tools kpeters$ ./rebview Bus error MiniMac:tools kpeters$

 [8/17] from: rgaither:triad:rr at: 24-Nov-2007 15:04


Hi Kai,
> Mac Mini, 6 months old, 2 GB Ram, SuperDrive: > > All worked under Tiger - yesterday I upgraded.... > > View dies instantly under Leopard - the others run
I'm on an older PPC mac but the Tiger to Leopard upgrade left View working just fine for me. FWIW, Rod.

 [9/17] from: kpeters:otaksoft at: 24-Nov-2007 15:54


On Sat, 24 Nov 2007 15:04:15 -0500, Rod Gaither wrote:
> Hi Kai,
That would have been my next question for everyone with 'working Leopards': I wiped my Tiger and then installed Leopard clean. Seems that the working ones are upgrades? Is that a valid assumption? Kai

 [10/17] from: edoconnor:g:mail at: 24-Nov-2007 19:07


Mine was an upgrade-- I did not wipe clean. On Nov 24, 2007 6:54 PM, Kai Peters <kpeters-otaksoft.com> wrote:

 [11/17] from: kpeters:otaksoft at: 25-Nov-2007 10:17


To prove my theory I did the following: 1) Wiped Leopard 2) Installed Tiger 3) Installed Rebol/View 4) Updated Tiger to Leopard Voila ~ View runs! I'd really like to know what made the difference.... Kai

 [12/17] from: rgaither:triad:rr at: 26-Nov-2007 22:21


Mine was an upgrade also. On Nov 24, 2007, at 7:07 PM, Ed O'Connor wrote:

 [13/17] from: henrik:webz:dk at: 29-Nov-2007 10:31


On 25/11/2007, at 1.07, Ed O'Connor wrote:
> Mine was an upgrade-- I did not wipe clean. > On Nov 24, 2007 6:54 PM, Kai Peters <kpeters-otaksoft.com> wrote:
<<quoted lines omitted: 8>>
>> >> Seems that the working ones are upgrades? Is that a valid assumption?
It would be nice to settle this once and for all to give a pointer to RT to maybe release a Leopard upgrade of R2 or at least some documentation on how to make it work. From AltME, I saw this: Using otool from Terminal, you can figure out what libraries, REBOL uses. It's man page is available at http://www.hmug.org/man/1/otool.php On my Tiger install: $ otool -L /usr/bin/rebol /usr/bin/rebol: /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.3) $ otool -L ./view ./view: /System/Library/Frameworks/Carbon.framework/Versions/A/ Carbon (compatibility version 2.0.0, current version 128.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.3) -- Regards, Henrik Mikael Kristensen

 [14/17] from: kpeters:otaksoft at: 29-Nov-2007 9:17


Here's what Leopard uses: MiniMac:Applications kpeters$ otool -L rebol rebol: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 128.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.4) MiniMac:Applications kpeters$ otool -L rebview rebview: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 128.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.4) HTH, Kai On Thu, 29 Nov 2007 10:31:51 +0100, Henrik Mikael Kristensen wrote:

 [15/17] from: henrik:webz:dk at: 30-Nov-2007 9:37


On 29/11/2007, at 18.17, Kai Peters wrote:
> Here's what Leopard uses: > MiniMac:Applications kpeters$ otool -L rebol
<<quoted lines omitted: 13>>
> version > 71.1.4)
$ otool -L /usr/bin/rebol /usr/bin/rebol: /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.3) $ otool -L view view: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 128.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.3) View is not working here under Leopard 10.5.1 on PPC, but Core is. -- Regards, Henrik Mikael Kristensen

 [16/17] from: rgaither:triad:rr at: 3-Dec-2007 19:16


Hi Guys, On Nov 30, 2007, at 3:37 AM, Henrik Mikael Kristensen wrote:
> On 29/11/2007, at 18.17, Kai Peters wrote: >> Here's what Leopard uses:
<<quoted lines omitted: 30>>
> version 71.1.3) > View is not working here under Leopard 10.5.1 on PPC, but Core is.
My version - Leopard 10.5.1 on PPC - both working - g5:~$ otool -L /usr/local/bin/rebol /usr/local/bin/rebol: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 128.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.4) g5:~$ otool -L /usr/local/bin/rebview /usr/local/bin/rebview: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 128.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 71.1.4) I'm not sure that tells us much. Core - 2.7.5.2.4 View - 2.7.5.2.4 FWIW, Rod.

 [17/17] from: henrik:webz:dk at: 6-Dec-2007 20:00


On 22/11/2007, at 08.51, Karim El Founas wrote:
> Hello, > > I'm just installing my dev environment on my new Mac and it seems > that's working. I installed the SDK and I can run the desktop. > > I never saw any bus error but, I need to do more tests.
Crashlogs are saved in /Users/<username>/Library/Logs/CrashReporter/ View puts a nice one in there. Maybe someone can tell what's going on? -- Regards, Henrik Mikael Kristensen

Notes
  • Quoted lines have been omitted from some messages.
    View the message alone to see the lines that have been omitted