Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

script error?

 [1/6] from: terry::depotcity::com at: 10-Feb-2001 0:15

I've got this error popping up randomly.... CGI Error The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are: ** Script Error: Invalid path value: part. ** Where: target: change/part target :replace len Where is this coming from? (It would appear to be a rebol word?) And why won't it go away? :( Terry Brownell

 [2/6] from: terry:depotcity at: 10-Feb-2001 0:39

I think I located the problem... asked: replace/all asking #" " #"+" I change it to... asked: replace/all asking " " "+" And it seems to work fine. The scary thing is, I don't recall putting hash marks in the script? Does this relate to the error message? Terry Brownell

 [3/6] from: terry:depotcity at: 10-Feb-2001 1:19

Oops... spoke too soon (and to myself it would appear). The script is designed to escape a string! called "asking" It's then attached to the end of a url and sent off (in theory) It's been working fine for months, but now it requires me to escape the string PRIOR to it reaching "asked"?? Otherwise I get the error message. if asking: "my string" it chokes. if asking: "my+string" it's fine if asking: is a single word "string" it's fine too. asked: replace/all asking " " "+" (chokes with the error message right here???)

 [4/6] from: gjones05:mail:orion at: 10-Feb-2001 6:05

Hi, Terry, I tried the "choker" on the following three versions: REBOL/View REBOL/Core REBOL/core (Experimental) and got the following results each time.
>> asking: "my string"
== "my string"
>> asked: replace/all asking " " "+"
== "my+string" Out of curiosity, are you using a different version? --Scott

 [5/6] from: terry::depotcity::com at: 10-Feb-2001 13:22

Re: script error? Solved?

There is a definite problem with the following, but only in CGI, works fine in the console. asking: {this is a string in which I want to replace all spaces with a "+" sign} asked: replace/all asking " " "+"
> > > ** Script Error: Invalid path value: part. > > > ** Where: target: change/part target :replace len
I hacked it by getting rid of it and letting the server escape the spaces... but why is this happening? Is because the plus sign is a global or can't use spaces with replace or ??? Terry Brownell

 [6/6] from: terry::depotcity::com at: 10-Feb-2001 14:26

Re: script error? DEFINATELY SOLVED!

ARRGHH! I feel so stupid. I used the global word "change" as a variable and reset it's value. Although I don't use the word "change" in any of the scripts, it is obviously used in the global word "replace" hence the trouble digging it out. Sheesh! Anonymous