Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

One problem solved

 [1/3] from: chalz::earthlink::net at: 18-Sep-2002 2:19

Well, I solved one of my own problems. It was a network timeout error. Default timeout was 30 seconds. It was taking ~45 to negotiate the connection with my FTP server. However, instead of telling me "network timeout", REBOL was telling me there was something wrong with my login - suggesting the name or password were fubar. Not the case at all. It just wouldn't tell me network timeout. Also, system/schemes/ftp/timeout: 0:02 sets it to a 2 minute timeout for FTP. Theoretically. With write/lines ftp://..... it still only waited 30 seconds before dying. I had to set system/schemes/default/timeout for it to work. *boggle* Should I post this to feedback, or is this a known problem, or am I just doing something dumbassed? Oh, er,, REBOL/Core for Windows. --Charles

 [2/3] from: jason:cunliffe:verizon at: 18-Sep-2002 2:41 #018 Sometimes REBOL has a network timeout error. How can I increase the network timeout value? 1-Jan-2000 Setting: system/schemes/default/timeout: 0:10 will set a ten minute timeout for all protocols. If you want to set a specific protocol, such as FTP, put that in place of the default. system/schemes/ftp/timeout: 0:10

 [3/3] from: chalz:earthlink at: 18-Sep-2002 15:53

Yes, I was there. That's where I found out how to update the setting. Thing is, it doesn't stay set. Also, when I used system/schemes/ftp/timeout, and I was trying to use write/lines ftp://.., it still used the 30sec timeout as opposed to the 2min timeout I had set.