Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

Problem with Mail Reader (readmail.r)

 [1/10] from: antoni2::gawab::com at: 26-Jun-2007 23:19

Anybody is currently using the Mail Reader (readmail.r) ? I tried, current version 4.14.9. Wonderful script. I can fetch all my mail smoothly, manage several mail accounts, folders, saving files, searching, everything works prima. But unfortunately cannot send mail with it. It gives a lack of authentication error message, in spite of setting up mail with set-net [... ]. Authentication works with the other mail scripts, both sending and receiving, so I suspect it is a problem related to this paticular script. Any ideas ? When try to send mail, error: Error sending mail to 'address-receiver...' Detailed message: Server error: tcp 530 5.7.0 Authentication required Near: [insert port reduce data] Where: none Have set mail settings with set-net [... full specs..] Checked net connection, smtp and pop server names, both quoted and unquoted, - as I mentioned, emailer.r works fine. Any ideas ? Antoni

 [2/10] from: philb:rebol::gmail at: 27-Jun-2007 8:39

Hi Antonio, I just looked at the script emailer.r which does bnothing special, so I dont see why readmail.r doesnt work. If you find out what is going wrong then let me know and I will update readmail.r. My ISP doesnt use Authentication so I can't easily test this. Regards, Phil Bevan On 6/27/07, Antonio <> wrote:

 [3/10] from: philb::rebol::gmail::com at: 27-Jun-2007 9:02

Hi Antonio, I think I may know what is wrong with the readmail.r script. It actually uses a patched version of the send function. This was patched to add the real names to the email sent. If the send function has chagned since the patch was created than this could well be causing a problem. Can you tell me what version of Veiw you are using? I will need to either re-patch the send function or remove the patch entirely. Regards, Phil Bevan On 6/27/07, Philip Bevan <> wrote:

 [4/10] from: antoni2::gawab::com at: 28-Jun-2007 1:08

Hi Philip, System is Windows XP. View version is, and readmail version: 4.14.9 ; My user.r file contains the complete set-net sentence, plus std stuff: (...) set-net [ none none none "user_name_equals_mail_adress" "password"] set-user-name "Tonio" (this is set in View, not the mail user-name) (...) I think this should be correct. The user.r file is located in C:/Docs and Settings/MyName/program_documents/rebol/ ... I dont think readmail reads it from anywhere else. Besides, as I said, emailer works ok, and so does mail fetching with readmail Thanks. I would like someone could test authentication with readmail.r, before to much work is done on this... Antoni --------------------------------------------- Free POP3 Email from Sign up NOW and get your account!!

 [5/10] from: btiffin:rogers at: 27-Jun-2007 22:17

I get failures here too. Authenticated server. Under Linux ESMTP send doesn't work at all. Under it DOES work from the console, even with set-net username 'ASK (a handy feature). readmail.r under error display is Authentication Required... under error display mail-send not found in fn-send-mail. set-net real username and password strings readmail 4.14.9 Brian On Wednesday 27 June 2007 21:08, Antoni wrote:

 [6/10] from: philb::rebol::gmail::com at: 28-Jun-2007 14:44

Hi Brian/Antonio, I found the problem last night .... the patch to the send function patched an old version of send. I will be updating this patch ASAP. After looking at it last night, I found that it was not a straightforwad fix, just removing the patch didnt work .... The problem with is also related to the patch, time permitting, I will also look at that tonight. Phil Bevan On 6/28/07, Brian Tiffin <> wrote:

 [7/10] from: philb::rebol::gmail::com at: 30-Jun-2007 0:42

Hi Antonio/Brian, I have uploaded a new version of readmail.r 4.14.14 to and to the library. I think this will fix the esmtp problem. Let me know how it goes .... Cheers Phil Bevan On 6/28/07, Philip Bevan <> wrote:

 [8/10] from: carl::cybercraft::co::nz at: 30-Jun-2007 20:46

Hi Phil, While you're on the job... :-( I've occasionally had emails arrive that give errors with Readmail, though I've always suspected they were malformed emails, and maybe deliberately so by spammers. But tonight I tried to register with Etsy (see: ) and I got the error with their confirmation email - and again when I asked them to re-send it. So I've a repeatable pattern here. I first get an alert saying this... parse-email-addrs expected data argument of type: string none Near: [data/to: parse-email-addrs data/to all [multiple data/cc: parse-email-addrs data/cc] ] Where: import-email then another one saying just this... invalid email data - data written to followed a little while later by Readmail crashing with this error... ** Script Error: gi_100 has no value ** Where: fn-get-mail-info ** Near: alert fn-gl gi_100 return 0 Note that if you (or anyone else) wants to try a Readmail test register with Etsy, that they only allow one user-name per email address - and that the user-name will be the name of your shop there, if you ever open one... (Well, you never know, if you're an artist...) Any thoughts on this? (Oh, and that was with both 4.14.9 and 4.14.14. I thought the upgrade might've fixed it, but it didn't - just stopped me sending emails... I've not looked into the latter yet though, so you can safely ignore it for now. 4.14.9 is still working for me.) -- Carl Read. On Saturday, 30-June-2007 at 0:42:41 Philip Bevan wrote,

 [9/10] from: philb:rebol:gm:ail at: 1-Jul-2007 16:35

Hi Carl, I have just registered with etsy. I did get the same error with their confirmation email. On first investigation it seems that their email has 2 versions of the To: fields in the header. Removing one of these enables the email to be opened. I will look at the I have corrected the other error (gi_100 has no value). Note: That if an email cannot be decoded it is still stored in your inbox, but with a .log extension as plain text. So you could read the mail with a text editor. If you can fix the error in the malformed email, you can change the extension to .eml and it will appear in your inbox. I will email you off list to and to see if we can sort out the send error. Cheers Phil On 6/30/07, Carl Read <> wrote:

 [10/10] from: carl::cybercraft::co::nz at: 1-Jul-2007 20:44

Hi Phil, Removing the extra 'To:' field allowed the email to be listed, but then it bounced when I replied to it as reqiired to confirn my Etsy registration. So I had to use Outlook to reply to an email for the first time since I started using Readmail! Bad Readmail... Yes, get in touch regarding the send error sometime. If Readmail's been updated again, I'll have another try with the new version soon. -- Carl Read. On Sunday, 1-July-2007 at 16:35:15 Philip Bevan wrote,