Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

browsing from the core [core]

 [1/4] from: alberto:origen:mx at: 23-Apr-2007 11:34


I've just notice the "browse" function didn't work in rebol core, at least this is true for rebol core version 2.6.2.3.1 for windows. The function is accepted but nothing happens, i.e. the browser isn't launched. Is this a known issue? Is an unimplemented feature? Do I need to setup something before use 'browse? Thanks - Alberto -- Usando el revolucionario cliente de correo de Opera: http://www.opera.com/mail/

 [2/4] from: dhsunanda:g:mail at: 23-Apr-2007 18:34


alberto wrote:
> I've just notice the "browse" function didn't work in rebol core, at least > this is true for rebol core version 2.6.2.3.1 for windows.
You may need to use set-browser-path The path set at installation may be wrong if you have changed / updated your default browser. Sunanda

 [3/4] from: alberto::origen::com::mx at: 23-Apr-2007 13:27


Sunanda, Thank you for your quick answer En Mon, 23 Apr 2007 12:34:08 -0500, Sunanda <dhsunanda-gmail.com> escribió:
> You may need to use > set-browser-path
I suspect that, but IIRC, 'set-borwser-path is only avaiable in some view betas, not in core nor view releases
> The path set at installation may be wrong if you have changed / > updated your default browser. >
Just FYI, In view 'browse works fine, I haven't change my default browser after "installation", well if we can call "installation" the procedure of copy and launch rebol/core. - alberto -- Usando el revolucionario cliente de correo de Opera: http://www.opera.com/mail/

 [4/4] from: btiffin::rogers::com at: 25-Apr-2007 15:52


On Monday 23 April 2007 13:34, Sunanda wrote:
> alberto wrote: > > I've just notice the "browse" function didn't work in rebol core, at
<<quoted lines omitted: 4>>
> updated your default browser. > Sunanda
As far I know, set-browser-path is deprecated for security reasons. Linux REBOL (again as far as I tested) calls /usr/bin/netscape "url" Windows? Don't know, but I'd guess it uses the default-browser registry entry? What that entry is called? Don't know. Hack workaround I've been using in my %user.r - which only loads in REBOL/View not REBOL/Core in my environment setup. linux?: equal? fourth system/version 4 if linux? [ attempt [unprotect 'browse] browse: func [value [any-string!] /only] [ call reform ["konqueror " rejoin [{"} value {"}]] ] ] For Windows, you'd want fourth system/version to be 3? Under my Debian system, konqueror is in the default system path, you may need to add "c:\bobloblaw\browser.exe /switches " rejoin bobloblaw to the call line to make sure REBOL can find it. Brian Tiffin

Notes
  • Quoted lines have been omitted from some messages.
    View the message alone to see the lines that have been omitted