Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

Weird error message...

 [1/11] from: arolls:idatam:au at: 8-Nov-2001 12:11

The answer is: You shouldn't be trying to do that because it doesn't do what you want, anyway :) I've occasionally noticed weird stuff like that when missing quotes etc. in the console. It -is- the front line, however. :)Anton

 [2/11] from: joel:neely:fedex at: 7-Nov-2001 0:01

The following occurred in a console session, after I hit the Enter key instead of the adjacent doublequote key. Notice the bizarre last line...
>> replace/all x "^/^/" "^/
** Syntax Error: Missing " at replace/all x "^/^/" "^/ ** Near: 0.1 * to-int (n + 1000 + 0.5) -jn- -- We've heard that a million monkeys at a million keyboards could produce the complete works of Shakespeare; now, thanks to the Internet, we know this is not true. -- Robert Wilensky joel#dot#neely#at#fedex#FIX#PUNCTUATION#dot#com

 [3/11] from: hallvard:ystad:helpinhand at: 7-Nov-2001 13:17

And look what I got when I copied and pasted your error:
>> replace/all x "^/^/" "^/
** Syntax Error: Missing " at replace/all x "^/^/" "^/ ** Near: type? tag-stuff Why rebol came up with the "type? tag-stuff" thing, beats me... But this clearly illustrates in what order things are done. In my console session, 'x had no value:
>> value? 'x
== false .. but that's an error for a later stage... ~H Joel Neely skrev (Wednesday 07.11.2001, kl. 07.01):

 [4/11] from: media:quazart at: 7-Nov-2001 7:50

what is a rounding expression doing there!?!? -MAxim

 [5/11] from: koopmans:itr:ing:nl at: 7-Nov-2001 13:44

What was the value of x? Tried it with x as copy {} but alas,.... --Maarten On Wednesday 07 November 2001 07:01, you wrote:

 [6/11] from: hallvard:ystad:helpinhand at: 7-Nov-2001 13:58

I think I got it. Take a look at this:
>> ^/
** Syntax Error: Invalid path -- ^/ ** Near: (line 1) ^/
>> "^/
** Syntax Error: Missing " at "^/ ** Near: print find krak str_HTML In the first example, ^/ creates an error (of course). In the second example, rebol must be looking back in history to find a match for the double quote, hence the rounding expression in Joels console session (did you do some rounding just before, Joel?) and the tag-stuff thing in mine (I sure did some tag-stuff!). Or am I completely in the wrong stratosphere here? ~H Media skrev (Wednesday 07.11.2001, kl. 13.50):

 [7/11] from: joel:neely:fedex at: 7-Nov-2001 1:06

Hi, Maarten, It was a string containing only a long run of newlines. I strongly suspect that there's some internal buffer glitch (an buffer that's not getting cleaned out, a dangling pointer, or some other such thing...) in console input handling or error construction from invalid console input. Just a guess... -jn- Maarten Koopmans wrote:
> What was the value of x? > Tried it with x as copy {} but alas,....
<<quoted lines omitted: 4>>
> > ** Near: 0.1 * to-int (n + 1000 + 0.5) > >
-- Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so. -- Douglas Adams joel!dot!neely!at!fedex!FIX!PUNCTUATION!dot!com

 [8/11] from: joel:neely:fedex at: 7-Nov-2001 8:44

Hi, Hallvard, Hallvard Ystad wrote:
> I think I got it. Take a look at this: > >> ^/
<<quoted lines omitted: 9>>
> just before, Joel?) and the tag-stuff thing in mine (I sure > did some tag-stuff!).
I had done some experimenting with rounding much earlier, but it had been a while. Repeating the experiment on my box at work...
>> "^/
** Syntax Error: Missing " at "^/ ** Where: halt-view ** Near: ff There was no occurrence of FF in my console transcript (which went back to the point at which REBOL was started. However, there *was* an occurrence of FF in a script file which I had DOne from the console. This seems to support the conjecture about leftovers or other internal pointer weirdness... -jn- -- This sentence contradicts itself -- no actually it doesn't. -- Doug Hofstadter joel<dot>neely<at>fedex<dot>com

 [9/11] from: mattsmac:hotmai:l at: 27-Oct-2003 14:53

Weird Error

The script I have going logs onto a server using Rugby. As an error check, if the client cannot connect to the server, I prompt the user to enter a new server IP address in a request/text box. Then I take this new IP address (in string form) and put it into the string "mainserver: context get-rugby-service tcp://" serverip ":8000" where serverip is the ip-string that was just obtained. Then I do that string. Basically, all this seems to work fine, but after that, I have an object I made to hold some message fields such as sender, date, and subject, all of which are read from an ODBC database. When I try to change the "." to ":" in the date field using tempmsg: make msg_info [ msgid: msg/1 from: msg/2 fromid: msg/3 subject: msg/4 date: copy/part msg/5 (length? msg/5) - 5 ] replace/all tempmsg/date "." ":" i get the error code ** Script Error: Cannot use path on logic! value ** Where: replace ** Near: target: change/part target :replace len This only happens when I change that IP address. If the default IP address works, then nothing goes wrong. And the tempmsg object gets populated properly also. So it's not like I'm not getting a database connection or anything easy like that. Anyone have any ideas? Matt

 [10/11] from: mattsmac::hotmail::com at: 27-Oct-2003 16:03

Sorry about that guys, it was just some weirdness in another part of my code.

 [11/11] from: greggirwin:mindspring at: 27-Oct-2003 13:56

Hi Matt, MM> replace/all tempmsg/date "." ":" MM> i get the error code MM> ** Script Error: Cannot use path on logic! value MM> ** Where: replace MM> ** Near: target: change/part target :replace len Looks like you've set CHANGE to a logic value somewhere in your code before this happens. Is that possible? -- Gregg

  • Quoted lines have been omitted from some messages.
    View the message alone to see the lines that have been omitted