Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

Free REBOL Servers

 [1/9] from: norsepower::uswest::net at: 6-Jan-2001 10:06

If you can find a free server which allows CGI, you can probably just go ahead and drop the /Core binary in your directory and use it.

 [2/9] from: ralph:abooks at: 8-Jan-2001 16:56

> If you can find a free server which allows CGI, you can probably just go > ahead and drop the /Core binary in your directory and use it. >
Ummm... I believe you would most definitely want to place REBOL outside your webspace or you would have a HUGE security hole... Many of the free web servers have a root directory, then a public_html directory with a cgi-bin directory. Make a directory for REBOL in the root directory, then call it in the normal manner for CGI programs. Should work nicely. --Ralph read REBOL FOR DUMMIES... buy it now at

 [3/9] from: rphilipp:suffolk:lib:ny:us at: 8-Jan-2001 18:14

I'm using tripod and they allow cgi scripts using perl. I copied rebol/core to my cgi-bin, that's the only directory where scripts can be run, and I ran a script which worked fine on my personal webserver. The results was that my script was not run but was displayed as a text file Maybe I need to have my webserver associate the .r extensions as an application? Robert P.

 [4/9] from: rchristiansen:pop:isdfa:sei-it at: 8-Jan-2001 17:34

One thing to check is to make sure your shebang has the right switches. Try the following: #!/path/to/rebol -cs You also want to make sure you have the correct rebol binary installed on the server. A common mistake is to upload the binary you are using locally, which most likely is not compiled for the operating system used on the web server. A final thing to check is to make sure your script is marked as executable. On a unix/linux server, you can type "chmod +x filename" to make your script executable.

 [5/9] from: brett:codeconscious at: 9-Jan-2001 11:56

One more thing. The server gives me an unhelpful "configuration error" message if I get the headers screwed up. I've used the following script to test configuration - it works. #!/directory-holding-the-rebol-executable/rebol --cgi REBOL [] print "Content-type: text/html^m^j" print "<HTML><BODY><PRE>" print "script-name: test.r.cgi" print join "script-time: " now print join "rebol-system-version: " system/version print mold system/options/cgi print "</PRE></BODY></HTML>" quit

 [6/9] from: brett:codeconscious at: 9-Jan-2001 11:26

One other thing I found. I have to give the cgi script an extension of ".cgi" before the webserver interprets it as such. Before I did this it just simply delivered me the contents of the script file. I guess my hosting provider has a strange setup. Brett.

 [7/9] from: brett:codeconscious at: 9-Jan-2001 12:20

Sorry if this appears twice. The first seemed to dissappear.

 [8/9] from: rphilipp:suffolk:lib:ny:us at: 8-Jan-2001 22:28

Thanks you everyone for your help. Its going to take a little time for me to implement your suggestions. I'll let you know how it works out. Robert P.

 [9/9] from: rphilipp:suffolk:lib:ny:us at: 6-Jan-2001 9:34

Hello, Does anyone know of any Free webservers out there like LYCOS where they would allow me to install/Run REBOL/Core scripts on the Server? Robert P.