Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

Presentation - XML-RPC

 [1/2] from: b::bord::arobasque::fr at: 16-Sep-2002 18:55

Hi everyone ! My name si Bruno Bord, I am a french Programmer and I began REBOL programming a few weeks ago. Useless to say, I'm more and more addicted to this powerful language. I have posted this question last week on the "general discussion forum" of, and one called Gregg advised me to try on this mailing list. (I've tried to search xml rpc on the eScribe archives, but I didn't see anything intersting) ---- 'tried a couple of client/server programming (using rugby, sometimes). But I think I have a problem with the xml-rpc implementation (rebXR). I don't understand how to make a rebol xml-rpc server. And I'm sorry, but the online documentation <> doesn't help... I launch the %xml-server-cgi.r program, and then the serve-cgi command with a simple function. But when I try to get back the result via a xml-rpc client, I get the message : ** Access Error: Cannot connect to <mymachine> ** Where: exec ** Near: con: open to-url rejoin ["tcp://" url/host ":" url/port-id] I tried to scan the different open ports of my machine, but it seems that there is not any (except the usual ones). I don't get it... Why don't the "cgi-server" open any port (80 ? default ?) Does anyone have a sample server-side .r file, in order to get this pain out of my ... oups :-) No' --- Keep REBOLING ! Bruno BORD [b--bord--arobasque--fr] ================================== Arobasque Informatique Atlantic Parc - Les pyramides n°14 ZA de Maignon 64600 ANGLET ================================== Tél : 05 59 42 51 00 Fax : 05 59 42 51 09 ================================== Site web : ================================== ********************************** Ce message électronique et tous les fichiers attachés qu'il contient sont confidentiels et destinés exclusivement à l'usage de la personne à laquelle ils sont adressés. Si vous avez reçu ce message par erreur, merci de le retourner à son émetteur. Les idées et opinions présentées dans ce message sont celles de son auteur, et ne représentent pas nécessairement celles de la société Arobasque Informatique. La publication, l'usage, la distribution, l'impression ou la copie non autorisée de ce message et des attachements qu'il contient sont strictement interdits. This e-mail and any files transmitted with it are confidential and intended solely for the use of the individual to whom it is addressed. If you have received this email in error please send it back to the person that sent it to you. Any views or opinions presented are solely those of its author and do not necessarily represent those of Arobasque Informatique. Unauthorized publication, use, dissemination, forwarding, printing or copying of this email and its associated attachments is strictly prohibited. **********************************

 [2/2] from: jason:cunliffe:verizon at: 16-Sep-2002 19:17

Hi Bruno Welcome to reboltopia!
> ** Access Error: Cannot connect to <mymachine> > ** Where: exec > ** Near: con: open to-url rejoin ["tcp://" url/host ":" url/port-id]
I just spent half an hour playing with it and I got similar error... I started by making a simple file for myself %testrebxr.r to make sure all the library files were loaded. Then tried the examples in the docs at When I ran the first simple client test, I get this XML error:
>> xmlrpc-exec [ examples.getStateName 41 ]
** XML-RPC Fault: Code: 6 Message: Poorly formed XML text, didn't find a '>' after a '<'. (At character #174.) ** Near: make error! e
I could not see where this is coming from [but did not try very hard]. I assume it is in the XML parse, though there may be xml-rpc changes at betty.userland since rebXR was written. Anyway, I invoked the server with the little test example in the Docs.
>> add 1 2
== 3
>> subtract 5 4
== 1
>> cgi-serve [ add subtract ]
Then opened another REBOL shell:
>> remote: make xmlrpc-client []
== http://localhost
>> remote/exec [add 1 2]
** Access Error: Cannot connect to localhost ** Where: exec ** Near: con: open to-url rejoin ["tcp://" url/host ":" url/port-id] same as you... so then I tried again with a fixed IP, and got this:
>> remote2: make xmlrpc-client [] >> remote2/set-server: ;my IP address created by DHCP
server ==
>> remote2/exec [add 1 2]
** Script Error: Cannot use path on none! value ** Where: rejoin ** Near: server/path server/target
Sorry I can not help your further right now. Perhaps this a clue. I'd like to use rebXR myself, so please keep me posted. ./Jason