Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

[REBOL] Re: problems with SDK under Windows 2000

From: ptretter:charter at: 28-Apr-2003 19:45

In short, you need to include more files for your LAYOUT problem such as view-vid.r. Also, there is currently a problem with encapping when you try to create a title for your encap. Therefore try it without adding an encap title. If I had a few more minutes I would have better explained but hopefully this gets you up running a bit faster. Paul Tretter ----- Original Message ----- From: "Marc Meurrens" <[rebol--meurrens--org]> To: <[rebol-list--rebol--com]> Sent: Monday, April 28, 2003 6:26 PM Subject: [REBOL] problems with SDK under Windows 2000 Hello all, I am new on this list; so let me first present myself and why I am using REBOL: as a professor of computer sciences in a Public Health School (Brussels University), I have decided to use REBOL for a cooperative medical application that need simultaneously (1) acces to the net, (2) encryption (as to protect medical data) and (3) a graphical user interface. Also, (4) I need to provide my end users (they are M.D.'s) with executables. For now, I have a REBOL script running perfectely under REBOL/View (free version) but without encryption of course. I have just purchased and installed the SDK on Windows 2000. ==== But I cannot run my existing script with my new licensed software and I cannot encapsulate it !!!!!!!!!!!! Here are the problems. 1) I understand from REBOL.COM site that SDK (that I just purchased ) is "View/PRO + other things" and that View/PRO is thus included in SDK. I observed that, in my purchased and downloaded zip file, there is no replacement for the free REBOL/View I used before. Is this a mistake? 2) Thus, in the absence of a View/PRO version, I try to use the FACE version (rebface.exe) after adding 3 #include's statements for %mezz.r , %prot.r and %view.r in my script as suggested in the documentation. Unfortunately, this result in an error "layout has no value". 3) I have tried to encapsulate the same script using enface.exe ( I have in fact tried with several simple scripts with several names.) The preprocessing seems to run well. The list of files is displayed properly. But then I receive the (encap) error message Output file cannot be created. Is it running? Is it a directory? Obviously, the name for the .exe file was available but enface.exe seems to be enable to write the file. 4) To make sure that all files are effectively found, I made some tries with all the executables, the scripts, the licence key, etc in just one unique directory. But it does not work better... === Anybody encountering similar problems? Any idea or suggestion ? Thanks... </marc> Prof. Ir Marc Meurrens TEL: +32 (0)2 537 2812 FAX: +32 (0)2 537 7645 GSM: +32 (0)475 46 2812 EMAIL: [marc--meurrens--org] URL: http://www.meurrens.org/ PGPKEY: http://www.meurrens.org/pgp/ Evitez les fichiers attachés au couriel, utilisez plutôt mon 'exchange area' : Please don't mail me attached files, instead, use my 'exchange area' : EXCHANGE AREA: http://www.meurrens.org/exchange/ (HTTP/FTP upload/download of temporary/persistent files)