Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search

[REBOL] Re: resize-vid

From: rotenca:telvia:it at: 27-Mar-2003 18:26

Hi Petr,
> 1) do-resize is way too similar to resize-do :-) Maybe 'do-resize could > be renamed to simply 'resize?
could be
> 2) I think that what we may often need is font resizing with face and > while resize-do with certain code can do nearly whatever, I call for > 'resize-font as a shortcut facet
i wanted to keep the source code short, there is some problem in setting the minimum. the maximum, how font must change when change hight and/or width of face...
> "delta" is the pain. I wonder if I am the only one who feels that way, > or is that anyone else with similar observations? The worst thing is - > how to do it more intuitively?
i'm open to any suggestion, perhaps a better name wold be delta-size or only size, i have no idea about another method, perhaps the user could define the functions by itself, but it must respect the argument orders, like happen in others language for hook functions
> 4) I wonder what others think of 'anchor facet in relation to > imagination what will actually e.g. anchor-xy 'button 1x0 do? :-) That > seems to be the toughest part for me, as it takes me a while to imagine, > what will actually happen to layout. But maybe it is just my slow > thinking? ... maybe it just requires a bit of a training :-)
in my approach anchor is the last option, when nothing else can help
> 5) naming concept - do-resize, resize-dump, auto-resize .... what about > wrapping them into context and allow resize/dump, resize/do, > resize/auto, resize/whatever? Just a thought ....
resize-dump is in a separate file, only a debug helper For the other names, can be, but it seems to me that the standard rebol code does not use too much this style of naming and, to be honest, i do not like to fill my code of paths. Thanks for your suggestions. --- Ciao Romano