Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

[REBOL] Re: Sloooooooow Rebol

From: SunandaDH:aol at: 28-Aug-2003 16:36

Marcelo
> Well, I think I forgot to configure something (I configure my PC using it: > http://www.jansfreeware.com/articles/pwsrebol.html). Someone can help me
???
> I've writing some simple Rebol scripts to run in command line and I love
it. Welcome to REBOL! I've been doing a lot of REBOL and CGI work lately. They are a good combination. I've not used REBOL with IIS, but in my experience, this sort of webserver timeout problem is caused by a malformed script. Try the following, in no particular order of importance: 1. make sure your *.r association is to a version of Core, not View (some people have reported that CGI and View don't mix). 2. End your script with a Quit rather than just dropping off the end. 3. Make absolutely sure the first thing printed is print "Content-Type: text/html^/" 4. Do the script in a REBOL console -- this will ensure that it doesn't have syntax errors. If it doesn't you should see your HTML printed in the console window. But, if you've put a Quit in, you may not see the console window -- it'll close darned fast -- so the trick is: a. Copy the script to the clipboard (ctrl+c) b. Open a REBOL console and type the command quit: :halt (note the two colons) c. Do this command: do read clipboard:// d. Check the HTML printed has a proper ending -- (last thing printed should be /html> 5. Does IIS have any decent logs? If so, there may be some more info there. Good luck! Sunanda