Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

[REBOL] Re: Compatibility REBOL 2.x / REBOL 3.0 ?

From: henrikmk::gmail::com at: 10-Mar-2009 15:00

On Tue, Mar 10, 2009 at 2:37 PM, Jedi <reboleur-free.fr> wrote:
> > Hi all :) > A question concerning REBOL 3.0 : > > Will be all the REBOL 2.x scripts still compatible with REBOL 3.0 ? > Especially REBOL/View : REBOL 2.x scripts fully compatible under REBOL 3. > 0 ?
No, there will be very little compatibility with regards to REBOL/View and VID scripts. R3 is a redesign from the ground up, keeping only the greatest parts of R2 and building entirely new parts and changing existing ones. As such, the GUI engine is completely rewritten with more simplicity and ease of use in mind. For Core only scripts, some compatibility remains and with a special R2-forward function package, some R3 functions have been backported to R2 in slower versions, but even there, some fundamental changes in R3 will not allow existing scripts to be easily interchangable with R2. To write future scripts to be compatible with both R2 and R3, you must write them with both R2 and R3 in mind. This is possible. But to run existing scripts, you must first rewrite or adapt them to R3. -- Regards, Henrik Mikael Kristensen