Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

[REBOL] Re: RFC: require-files block in the Rebol header

From: brett:codeconscious at: 5-Aug-2002 17:38

Hi Andrew,
> I use this format for my Rebol/Values scripts:
...
> Needs: [ > %"Common Parse Values.r" > %ML.r > ] > ] > > Basically, just implementing the 'Needs header as was mentioned by Car, > IIRC, some time ago.
REBOL checks the Needs header but I don't know what all the allowable formats are. I do know you can get it to check the product and version at least, but it does not seem to check files. For example, try using Core to DO a file that contains this: REBOL [ Needs: [view] ] print "hello" This Needs: [core 2.5.3] and this Needs: 2.5.3 also work. They seem to be minimum requirements, but I reckon it could be useful to be able to specify a maximum version too. Regards, Brett.