Mailing List Archive: 49091 messages
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

[REBOL] Re: ANN: rebol-framework-006

From: petr:krenzelok:trz:cz at: 17-Jan-2003 13:17

Boleslav Brezovsky wrote:
>Hi pekr, > >so you don't unzip, you use WinCMD (yes Total for legal reasons I >know...) >
yes ...
>for extracting and then you go to console and you DO NOT double >click on unpacked scripts right in WinCMD? :) >
What do you smile at? Each of use uses own patterns we follow while working with computer. I have plenty of windows opened. In quick-launch panel I have two rebol icons - IOS and View, so I went to View console - I then use tab key as a name completion feature. I often use console as kind of a rebol shell ...
> Well, people are different >;) >
Maybe I would not be different, if I would not was forced to use different rebol kernels. Which one am I supposed to associate my .r files to? Is that old view? View beta? Link? Command/View? Heh? So, I will wait once there is rebol/base only executable for all rebol language products + set of components and their versioning - then I will associate my .r file to one and only rebol.exe file ... maybe :-) I think it will not happen though .... and some ppl here will suddenly try to reming me of so called "dll hell" principle, while they are not afraid incompatibilities across various rebol kernels available ... ;-)
>But I tried it both from console and from WindowsCommander and I'm not >able to run it. >Different errors from console and from windows, strange. > >when I double click %rebol-framework.r I've got > >** Script Error: object-factory has no value >** Where: do-boot >** Near: database!: object-factory [ > file-format-version: make tuple! 0.0.1 > data: graph!/new [] > bot: graph!/new [] >] > >and when I run RFM from console I've got > >** Script Error: split-path expected target argument of type: file url >** Near: second split-path system/options/script >
yes, this one happens because Robert applies 'split-path to system/script/options ... the field is always 'none, unless you double-click the script and let your association launch rebol for you ... at least it works here that way ...
>when I run rfm-gui.r from WinCMD I've got this error > >Saving databse none >Loading new file data/example.rfm_graph >** Access Error: Cannot open /c/view/rfm/gfx/arrow-up-c.png >** Where: forever >** Near: load %gfx/arrow-up-c.png load %gfx/arrow-dn-c.png load > >and yes, there's no directory %gfx in rfm folder. >
there is styles/gfx subdir ... hmm, I wonder what is going on as it works here ...
>Something must be wrong with RFM. It's the first version I've tried, >maybe succesful people tried some version before and now they've got >some needed files on their disks which are not present in 0.0.6 ? I >don't know. > >PS: Oh, directory %styles/ is full of Cyphre's styles I was forbidden to >redistribute as part of Bunkas. As I said, people are different. And >some are allowed to do something what the others are not allowed to do. >Good to know. Or maybe Bunkas just weren't so 'proffesional' and >'representative' for Cyph's styles? >
ask Cyphre ... I think that you should talk one to each other, rather then talk via PS: field of email messages :-) Have you asked Cyphre if you can use his stuff for your work or you just used it "silently" without letting him know or giving him a credit in your Bunkas work? Is Cyphre's stuff publicly released? If not, you should ask him ... I can see no reason why he would not allow you to use his work ... :-) Cheers, -pekr-